Search Unity

Unity 3.4 Hotfix for new Android devices

November 1, 2012 in Technology | 1 min. read
Placeholder image Unity 2
Placeholder image Unity 2
Topics covered
Share

With the new Nexus 4 and Nexus 10 from Google announced on Monday we noticed a compatibility problem between older games based on Unity 3.4.x and the new Android OS 4.2. Specifically, older games would crash (or otherwise malfunction) when run on Android OS 4.2. The Unity 3.5 series and the upcoming Unity 4.0 does not suffer from this issue.

While we always encourage our users to use the most recent version of Unity, since it includes improvements and fixes for other problems as well, we also acknowledge the fact that upgrading an old, otherwise fully functional, already released title might not be time well spent for some developers.

Therefore we applied the necessary changes on the old Unity 3.4 sourcetree to bring you a Unity 3.4.2 hotfix. Please note that this release is provided as-is, and that only minimal testing has been done. It's also only suitable for Android development - no other platforms are supported. If you have a title currently in development, and still use Unity 3.4, we strongly suggest you ignore this hotfix release, and instead upgrade to Unity 3.5 (or Unity 4.0).

November 1, 2012 in Technology | 1 min. read
Topics covered